WordPress Plugins richtig auswählen

Es gibt inzwischen zu ziemlich jedem speziellen Anwendungsfall passende WordPress Plugins. In vielen Fällen sogar mehrere hundert. Manchmal klingen die Beschreibungen nach dem passenden Werkzeug. Aber sehr oft sind die Kurzbeschreibungen irreführend. Also, wie finden Sie heraus, welches WordPress Plugin zu Ihrer Anforderung passt und ob es mit Ihrem Theme harmoniert? Oder wie entscheiden Sie sich richtig, wenn Sie für Ihren Anwendungsfall mehrere Plugins zur Auswahl haben?  Und dann ist da noch die Problematik der (nicht)kompatiblen PHP-Versionen: Sie installieren ein Plugin, und plötzlich ist die Webseite irgendwie weg. Wie können Sie das vermeiden?

Tatsächlich gibt es ein paar Kriterien, Tricks und Kniffe, um das zu Ihren Anforderungen passende Plugin zu finden. Diese zeigen wir an einem konkreten und gar nicht so seltenen Praxisbeispiel. Dabei erläutern wir Ihnen unseren Entscheidungsprozess. Damit sollten dann Sie das grundsätzliche Know how haben, mit dem Sie IHRE geeigneten WordPress Plugins finden und einsetzen. Aber einen Zahn müssen wir Ihnen gleich ziehen: das Suchen und Ausprobieren kostet immer mehr Zeit, als Sie sich vorgenommen haben. Egal wie viele Tipps Sie sich aus dem Netz fischen.

Grundsätzliche Auswahlkriterien für passende WordPress Plugins

Dieses Mal plaudern wir ein wenig aus dem Nähkästchen. Wenn Sie regelmäßig Webseiten mit WordPress „bauen“, dann kennen Sie vielleicht die eine oder andere Methode. Prima, in diesem Fall fühlen Sie sich einfach bestätigt, alles richtig zu machen. Für alle anderen haben wir jetzt ein paar Tipps auf Lager.

Wenn Sie nach einem passenden Plugin für Ihre WordPress-Installation suchen, dann müssen Sie folgende Informationen parat haben:

  1. Mit welcher PHP Version arbeiten Sie auf Ihrem WordPress Server?
    Die Aktualisierung von WordPress CMS, Themes und Plugins ist mit viel Aufwand verbunden.  Einerseits für die Open Source Entwickler, die das quasi als Hobby betreiben. Andererseits auch für Ihre Agentur und den Webserver-Betreiber Ihrer WordPress Instanz. PHP-Pflege ist ein arbeitsaufwendiges und sensibles Thema. Daher kann es sein, dass Ihr Plugin Favorit nicht zu den bestehenden Rahmenbedingungen passt.
  2. Welches ist Ihre WordPress-Version?
    Die aktuelle Version (Stand 25.01.22) ist 5.8.3. Aber wie bereits unter 2. beschrieben, pflegen viele ihre WordPress Installation aus genannten Gründen häufig nur sporadisch. Genauso schnell veralten auch Plugins, so dass dies nicht zueinander passt.
  3. Brauchen Sie eventuell Support?
    Dann sollte es zu dem meist kostenlosen „Lite“ Plugin auch eine „Pro“ kostenpflichtige Version geben. Hier gibt es verschiedene Lizenzmodelle. Erfahrungsmäßig reicht eine Viertel-, Halb- oder Ganzjahreslizenz zur Ersteinrichtung. Diese kosten in der Regel nur ein paar EURO.

Die Suche nach dem richtigen Plugin

Zum besseren Verständnis haben wir uns ein Beispiel aus einem aktuellen Projekt ausgesucht. Die Anforderung lautet: wir brauchen einen Lageplan, auf dem mehrere Orte gezielt markiert werden sollen. Wegen der Datenschutzproblematik sollte dieses WordPress Plugin NICHT auf Google Maps basieren. Alles steht und fällt mit dem richtigen Suchbegriff. Und das ist nicht ganz so einfach wie gedacht. Denn unsere Vorstellung einer möglichen Plugin-Bezeichnung weicht nämlich oft von den offiziellen Fachbegriffen ab.

Die Suche über WordPress Plugins Seiten

WordPress-Profis suchen natürlich gleich hier: https://de.wordpress.org